Investigating issues with Browser Extension

Incident Report for Conveyor

Resolved

We've identified the issue and have deployed a fix. We will continue monitoring.
Posted Mar 13, 2026 - 09:45 PDT

Investigating

We are currently investigating reports that the browser extension is not working for some users.
Posted Mar 13, 2026 - 09:13 PDT
This incident affected: app.conveyor.com.