Delays with dashboards and certain integrations

Incident Report for Conveyor

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:49 PDT

Monitoring

The Conveyor application remains functional during the AWS operational issue in US-East-1 (https://health.aws.amazon.com/health/status). However, the following dashboards and integrations are experiencing delays:
- Summary metrics on the Conveyor Dashboard
- Integrations powered by Paragon (Microsoft Teams, Notion, Hubspot)

We continue to monitor the situation and will provide updates as the situation evolves.
Posted Oct 20, 2025 - 08:52 PDT
This incident affected: app.conveyor.com.