Status Update - Trust Center Outage

Incident Report for Conveyor

Resolved

We believe this incident is fully resolved and apologize for the disruption.
Posted Dec 04, 2025 - 14:00 PST

Update

We have identified and addressed the root cause that led to this issue recurring. We believe that we have addressed the underlying issue, but continue to monitor and investigate.
Posted Dec 04, 2025 - 13:26 PST

Update

We have identified that this issue has recurred but are working to address the underlying root cause with urgency to fully restore stable service to the impact set of Trust Centers. We apologize for this issue.
Posted Dec 04, 2025 - 13:04 PST

Monitoring

Trust Centers are operational and we continue to monitor this with a high priority.
Posted Dec 04, 2025 - 12:55 PST

Identified

Unfortunately this issue has recurred for a subset of Trust Centers and continue to investigate with a high priority. We apologize for this disruption.
Posted Dec 04, 2025 - 12:42 PST

Update

We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 12:39 PST

Monitoring

All Trust Centers are now operational and we continue to monitor this situation and identify a root case.
Posted Dec 04, 2025 - 12:36 PST

Update

We have identified only a subset of Trust Centers are impacted and are working through our Incident Response process to identify and resolve the issue.
Posted Dec 04, 2025 - 12:31 PST

Update

We are currently experiencing an outage affecting Trust Center access. Our team is actively investigating the issue and working to restore full functionality as quickly as possible.
Posted Dec 04, 2025 - 12:25 PST

Investigating

We are currently experiencing an outage affecting Trust Center access. Our team is actively investigating the issue and working to restore full functionality as quickly as possible.
Posted Dec 04, 2025 - 12:20 PST
This incident affected: app.conveyor.com and Hosted Trust Centers.