Intermittent 502 Bad Gateway on Hosted Trust Centers

Incident Report for Conveyor

Resolved

Our platform provider notified us that we experienced these intermittent connection failures related to DNS resolution issues on their end. This incident has been resolved and all services are functioning as expected.
Posted Mar 17, 2026 - 16:39 PDT

Monitoring

We have completed a restart of a failing service and we believe has resolved this issue. We continue to monitor the situation and identify a root cause.
Posted Mar 17, 2026 - 14:57 PDT

Investigating

We are seeing reports of intermittent 502 errors when accessing hosted Trust Centers. We have activated our Incident Response Plan and are investigating the possible cause of this disruption.
Posted Mar 17, 2026 - 14:15 PDT
This incident affected: Hosted Trust Centers.